Phone Support

Incident Report for OpenSRS

Resolved

This incident has been resolved. Phone support is fully restored.
Posted Jan 13, 2026 - 20:46 UTC

Monitoring

The issue has been identified and a fix has been implemented. The results are being monitored.
Posted Jan 13, 2026 - 18:01 UTC

Investigating

We are currently experiencing issues with our phone support service provider, which is affecting customers' ability to reach us by phone. For support please connect with us via chat or email for assistance until this is resolved. Thank you for your understanding.
Posted Jan 13, 2026 - 17:42 UTC
This incident affected: Reseller Support.