Domains Platform

Incident Report for OpenSRS

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 16:36 UTC

Monitoring

A fix has been implemented, and services have been restored to normal. We are now monitoring the stability of the service before closing off this case.
Posted Sep 05, 2025 - 15:19 UTC

Update

The issue has been identified, and work is being done to rebalance storage. Note that as this is being worked on it's expected the latency issues will continue.
We'll post updates as they become available.
Posted Sep 05, 2025 - 13:46 UTC

Identified

At this time we’ve identified the issue, and are working to apply a fix to restore timely responses.

Thank you for your patience.
Posted Sep 05, 2025 - 13:30 UTC

Investigating

We are currently experiencing intermittent delays with domains requests. This following actions may be delayed or respond with an error:

- availability checks
- registrations
- renewals
- transfers
- modifications

This will have no effect on registered domains. We will post updates as we work on this issue.
Posted Sep 05, 2025 - 12:31 UTC
This incident affected: APIs (OpenSRS API, OpenHRS API), Control Panels (Reseller Control Panel, Classic RWI, End User Control Panel, Storefront), and Domain Services (Core ccTLDs, Other gTLDs, Other ccTLDs).